blob: 7a6437dc5389e889c0457f37b74fcc225e5430d9 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "This project aims to provide an object-oriented Python WebDAV client-side library\
2 based on Python`s standard httplib and Greg Stein`s davlib.\
3 The client shall fully support RFCs 4918 (basic specification),\
4 3744 (access control), and 3253 (versioning)."
5SECTION = "devel/python"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://src/webdav/WebdavClient.py;endline=15;md5=a1520fad859feb7b0d7f05277bc6ce48"
8HOMEPAGE = "http://sourceforge.net/projects/pythonwebdavlib/"
9SRCNAME = "Python_WebDAV_Library"
10DEPENDS = "python"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/pythonwebdavlib/Python%20WebDAV%20Library%20-%20${PV}/${SRCNAME}-${PV}.zip"
13SRC_URI[md5sum] = "8e49e0ecc5b4327c4f752a544ee10e1a"
14SRC_URI[sha256sum] = "72c029ad1e25de950f59c2f1812d009d2c1691b70e4b5b09f1af9006e8fd5f23"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit distutils
19