blob: 712c4b97ab8b152c66363f0aef949dbcd8cb7ade [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
2an interface to libparted, the GNU parted library for disk partitioning and \
3filesystem manipulation."
4SUMMARY = "Python bindings for libparted"
5HOMEPAGE = "https://github.com/rhinstaller/pyparted"
6LICENSE = "GPL-2.0+"
7LIC_FILES_CHKSUM = "\
8 file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
9 file://src/_pedmodule.c;startline=10;endline=22;md5=ebcb25dde1ac9c46e986dec79b404e7e \
10"
11DEPENDS += "parted python-re"
12
13PV = "3.10.7+git${SRCPV}"
14
15# upstream only publishes releases in github archives which are discouraged
16SRCREV = "69c4a478e43d3eff6ae3a0116fa38da06776d5f5"
17SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https \
18 file://0001-fix-version-float-check.patch \
19"
20S = "${WORKDIR}/git"
21
22inherit distutils
23
24RDEPENDS_${PN} += "python-stringold python-codecs python-math parted (>= 2.3)"
25RDEPENDS_${PN}_class-native = ""
26
27BBCLASSEXTEND += "native"