blob: 31e72e562ac2701bd23e1ff5091f75df7047378a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Makes sure Ruby applications run the same code on every machine."
2DESCRIPTION = "Bundler makes sure Ruby applications run the same code \
3on every machine. It does this by managing the gems that the \
4application depends on. Given a list of gems, it can automatically \
5download and install those gems, as well as any other gems needed by \
6the gems that are listed. Before installing gems, it checks the \
7versions of every gem to make sure that they are compatible, and can \
8all be loaded at the same time. After the gems have been installed, \
9Bundler can help you update some or all of them when new versions \
10become available. Finally, it records the exact versions that have \
11been installed, so that others can install the exact same gems."
12
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://LICENSE.md;md5=196bb963e601609817d7e9ac9a64a867"
15
16SRCREV = "06dc8472b9142fd6aaefff780d6d252c20dc2a04"
17
18BRANCH = "1-9-stable"
19PV = "1.9.4"
20
21S = "${WORKDIR}/git"
22
23SRC_URI = " \
24 git://github.com/bundler/bundler.git;branch=${BRANCH} \
25 "
26
27inherit ruby
28
29RDEPENDS_${PN} = "git"
30
31BBCLASSEXTEND = "native"