blob: da33115aa0d25c8866f872585fb6ab4dab1ba2ee [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Websocket module for Apache web server"
2DESCRIPTION = "Process requests using the WebSocket protocol (RFC 6455)"
3HOMEPAGE = "https://github.com/jchampio/${PN}/"
4SECTION = "net"
5LICENSE = "Apache-2.0"
6
7inherit autotools-brokensep pkgconfig
8
9DEPENDS = "apache2 apache2-native"
10RDEPENDS_${PN} += "apache2"
11
12# Original (github.com/disconnect/apache-websocket) is dead since 2012, the
13# fork contains patches from the modules ML and fixes CVE compliance issues
14SRC_URI = "git://github.com/jchampio/apache-websocket.git"
15
16SRCREV = "f5230d8c520dccf8631da94bf90c23f3c1100dcc"
17
18PV = "0.1.1"
19
20S = "${WORKDIR}/git"
21
22LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
23
24EXTRA_OECONF = "APACHECTL=${STAGING_DIR_TARGET}${sbindir}/apachectl \
25 LIBTOOL=${STAGING_DIR_TARGET}${bindir_crossscripts}/${HOST_SYS}-libtool"
26
27do_install() {
28 install -d ${D}${libdir}/apache2/modules/
29 install ${B}/.libs/mod_websocket.so ${D}${libdir}/apache2/modules/
30}
31
32FILES_${PN} += " ${libdir}/apache2/modules/* "
33FILES_${PN}-dbg += " ${libdir}/apache2/modules/.debug/* "