blob: 5287ea42c184d167d2fd8a59ba9573b3bd10d412 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Cherokee Web Server fast and secure"
2SUMMARY_cget = "Small downloader based in the Cherokee client library"
3HOMEPAGE = "http://www.cherokee-project.com/"
4SECTION = "network"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8PR = "r9"
9
10DEPENDS = "libpcre openssl mysql5 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
11
12SRC_URI = "http://www.cherokee-project.de/mirrors/cherokee/1.2/${PV}/cherokee-${PV}.tar.gz \
13 file://cherokee.init \
14 file://cherokee.service \
15 file://cherokee-install-configured.py-once.patch \
16"
17SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb"
18SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d"
19
20inherit autotools pkgconfig binconfig update-rc.d systemd
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[ffmpeg] = "--with-ffmpeg,--without-ffmpeg,libav"
24PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
25PACKAGECONFIG[geoip] = "--with-geoip,--without-geoip,geoip"
26
27EXTRA_OECONF = "--disable-static \
28 --disable-nls \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
30 --with-wwwroot=${localstatedir}/www/cherokee \
31"
32
33do_install_append () {
34 install -m 0755 -d ${D}${sysconfdir}/init.d
35 install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee
36
37 # clean up .la files for plugins
38 rm -f ${D}${libdir}/cherokee/*.la
39
40 install -d ${D}${systemd_unitdir}/system
41 install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system
42 rmdir "${D}${localstatedir}/run"
43 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
44}
45
46# Put -dev near the front so we can move the .la files into it with a wildcard
47PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget"
48
49FILES_cget = "${bindir}/cget"
50FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}"
51FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}"
52FILES_libcherokee-base = "${libdir}/libcherokee-base${SOLIBS}"
53
54# Pack the htdocs
55FILES_${PN} += "${localstatedir}/www/cherokee"
56
57CONFFILES_${PN} = " \
58 ${sysconfdir}/cherokee/cherokee.conf \
59 ${sysconfdir}/init.d/cherokee \
60"
61
62INITSCRIPT_NAME = "cherokee"
63INITSCRIPT_PARAMS = "defaults 91 91"
64
65RPROVIDES_${PN} += "${PN}-systemd"
66RREPLACES_${PN} += "${PN}-systemd"
67RCONFLICTS_${PN} += "${PN}-systemd"
68SYSTEMD_SERVICE_${PN} = "cherokee.service"