blob: be8ed37b972b335d4d651cdb9ed60af0672cc470 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Fast and Lightweight HTTP Server for Linux"
2HOMEPAGE = "http://monkey-project.com"
3BUGTRACKER = "https://github.com/monkey/monkey/issues"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
7
8SECTION = "net"
9
10SRC_URI = "http://monkey-project.com/releases/1.5/monkey-${PV}.tar.gz \
11 file://monkey.service \
12 file://monkey.init"
13
14SRC_URI[md5sum] = "9699e4c9ea6ce6b989907c252ae80254"
15SRC_URI[sha256sum] = "7c3d845306aa74ee6effd7ab6169d16ac4e6450e564954d0d0baa2d1e9be1a22"
16
17EXTRA_OECONF = "--plugdir=${libdir}/monkey/ \
18 --logdir=${localstatedir}/log/monkey/ \
19 --pidfile=${localstatedir}/run/monkey.pid \
20 --default-user=www-data \
21 --datadir=${localstatedir}/www/monkey/ \
22 --sysconfdir=${sysconfdir}/monkey/ \
23 --enable-plugins=* \
24 --disable-plugins=mbedtls \
25 --debug \
26 --malloc-libc"
27DISABLE_STATIC = ""
28
29inherit autotools-brokensep pkgconfig update-rc.d systemd
30
31INITSCRIPT_NAME = "monkey"
32INITSCRIPT_PARAMS = "defaults 70"
33
34SYSTEMD_SERVICE_${PN} = "monkey.service"
35
36FILES_${PN} += "${localstatedir}/www/monkey/"
37
38CONFFILES_${PN} = "${sysconfdir}/monkey/monkey.conf \
39 ${sysconfdir}/monkey/sites/default \
40 ${sysconfdir}/monkey/monkey.mime \
41 ${sysconfdir}/monkey/plugins.load \
42 ${sysconfdir}/monkey/plugins/proxy_reverse/proxy_reverse.conf \
43 ${sysconfdir}/monkey/plugins/mandril/mandril.conf \
44 ${sysconfdir}/monkey/plugins/fastcgi/fastcgi.conf \
45 ${sysconfdir}/monkey/plugins/logger/logger.conf \
46 ${sysconfdir}/monkey/plugins/cgi/cgi.conf \
47 ${sysconfdir}/monkey/plugins/cheetah/cheetah.conf \
48 ${sysconfdir}/monkey/plugins/dirlisting/dirhtml.conf \
49 ${sysconfdir}/monkey/plugins/dirlisting/themes/guineo/header.theme \
50 ${sysconfdir}/monkey/plugins/dirlisting/themes/guineo/footer.theme \
51 ${sysconfdir}/monkey/plugins/dirlisting/themes/guineo/entry.theme \
52 ${sysconfdir}/monkey/plugins/auth/README \
53 ${sysconfdir}/monkey/plugins/auth/monkey.users \
54 "
55
56do_install_append() {
57
58 mkdir -p ${D}${sysconfdir}/init.d
59 install -m 0755 ${WORKDIR}/monkey.init ${D}${sysconfdir}/init.d/monkey
60
61 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
62 install -d ${D}${systemd_unitdir}/system
63 install -m 644 ${WORKDIR}/monkey.service ${D}/${systemd_unitdir}/system
64 fi
65}