blob: ac321857b589b8f4480c074555fd283230be2d02 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Web-based MySQL administration interface"
2HOMEPAGE = "http://www.phpmyadmin.net"
3# Main code is GPLv2, libraries/tcpdf is under LGPLv3, js/jquery is under MIT
4LICENSE = "GPLv2 & LGPLv3 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://libraries/tcpdf/LICENSE.TXT;md5=5c87b66a5358ebcc495b03e0afcd342c"
7
8SRC_URI = "https://files.phpmyadmin.net/phpMyAdmin/4.5.0.2/phpMyAdmin-4.5.0.2-all-languages.tar.xz \
9 file://Port-content-spoofing-fix-CVE-2015-7873.patch \
10 file://apache.conf \
11 file://phpmyadmin-CVE-2015-8669.patch \
12"
13
14SRC_URI[md5sum] = "2d08d2fcc8f70f88a11a14723e3ca275"
15SRC_URI[sha256sum] = "d2e90ea486d90b4ebe5eb02d7ad349ad2916c12a8981f98553395ef78d22a8ec"
16
17S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages"
18
19inherit allarch
20
21do_install() {
22 install -d ${D}${datadir}/${BPN}
23 cp -R --no-dereference --preserve=mode,links -v * ${D}${datadir}/${BPN}
24 chown -R root:root ${D}${datadir}/${BPN}
25 # Don't install patches to target
26 rm -rf ${D}${datadir}/${BPN}/patches
27
28 install -d ${D}${sysconfdir}/apache2/conf.d
29 install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
30
31 # Remove a few scripts that explicitly require bash (!)
32 rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh
33}
34
35FILES_${PN} = "${datadir}/${BPN} \
36 ${sysconfdir}/apache2/conf.d"
37
38RDEPENDS_${PN} += "bash"