blob: f27396c008159af38213ccfda682e2550fef618e [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "Parole is a modern simple media player based on the GStreamer framework"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/parole"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5
6inherit xfce-app gtk-doc mime
7
8DEPENDS += " \
9 glib-2.0 \
10 dbus-glib \
11 gtk+3 \
12 \
13 xfce4-dev-tools-native \
14 libxfce4util \
15 libxfce4ui \
16 xfconf \
17 \
18 gstreamer1.0-plugins-base \
19 taglib \
20"
21
22SRC_URI[md5sum] = "361e3059f1263c76a3711db2c7c1a97b"
23SRC_URI[sha256sum] = "4b216f5200490f8d2a9bf1b3fcd9a8b20834c95249bf13b9170c82e1fcbd80f4"
24
25RDEPENDS_${PN} += "gstreamer1.0-plugins-good"
26
27PACKAGECONFIG ??= "notify"
28PACKAGECONFIG[clutter] = "--enable-clutter, --disable-clutter, clutter"
29PACKAGECONFIG[notify] = "--enable-notify-plugin, --disable-notify-plugin, libnotify"
30
31FILES_${PN} += " \
32 ${datadir}/appdata \
33 ${libdir}/parole-0/*.so \
34"
35FILES_${PN}-dbg += "${libdir}/parole-0/.debug"
36FILES_${PN}-dev += "${libdir}/parole-0/*.la"