blob: c2e0ed912545d9208ba89ceba1d4ab2ca2ef3dfa [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Sensors plugin for the Xfce Panel"
2HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b94789bed9aec03b9656a9cc5398c706"
5
6inherit xfce-panel-plugin
7
8SRC_URI[md5sum] = "33c2e343c1224d9c4ae757a70cbe08eb"
9SRC_URI[sha256sum] = "235ef842bd45e701bceebb21a384ab09f21afceea8ed95f91bb4c6cf3abe1bc0"
10
11EXTRA_OECONF = " \
12 --disable-procacpi \
13 --disable-sysfsacpi \
14 --disable-xnvctrl \
15"
16
17do_configure_prepend() {
18 sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
19}
20
21PACKAGECONFIG ??= "libsensors"
22PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
23PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
24PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"
25PACKAGECONFIG[libnotify] = "--enable-notification,--disable-notification, libnotify"
26
27FILES_SOLIBSDEV = "${libdir}/xfce4/modules/lib*${SOLIBSDEV}"