blob: f1b5ae5878475a8059dc197fd4b17b7b553f3360 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION="Application library for the Xfce desktop environment"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo"
6DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native intltool-native"
7
8inherit xfce pythonnative perlnative gtk-doc
9
10# SRC_URI must follow inherited one
11SRC_URI += " \
12 file://exo-no-tests-0.8.patch \
13 file://configure.patch \
14"
15
16SRC_URI_append_class-native = " \
17 file://reduce-build-to-exo-csource-only.patch \
18"
19
20SRC_URI[md5sum] = "895e4f38d2cfe58d69679e2902a335a5"
21SRC_URI[sha256sum] = "1cc0e5a432e050a5e5aa64d126b988f4440da4f27474aaf42a4d8e13651d0752"
22
23PACKAGES =+ "exo-csource"
24
25# Note: python bindings did not work in oe-dev and are about to be moved to
26# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
27FILES_${PN} += "${datadir}/xfce4/ \
28 ${libdir}/xfce4/exo-1 \
29"
30
31FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \
32"
33
34FILES_exo-csource += "${bindir}/exo-csource"
35
36BBCLASSEXTEND = "native"