blob: c07188f6e0eb3372f774d0ee703afe323c284d4d [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "All packages for full XFCE installation"
2SECTION = "x11/wm"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
5
6PR = "r10"
7
8inherit packagegroup
9
10# mandatory
11RDEPENDS_${PN} = " \
12 packagegroup-xfce-base \
13"
14
15# nice to have
16RRECOMMENDS_${PN} = " \
17 xfwm4-theme-daloa \
18 xfwm4-theme-kokodi \
19 xfwm4-theme-moheli \
20 \
21 xfce-dusk-gtk3 \
22 \
23 xfce4-cpufreq-plugin \
24 xfce4-cpugraph-plugin \
25 xfce4-datetime-plugin \
26 xfce4-eyes-plugin \
27 xfce4-clipman-plugin \
28 xfce4-diskperf-plugin \
29 xfce4-netload-plugin \
30 xfce4-genmon-plugin \
31 xfce4-xkb-plugin \
32 xfce4-wavelan-plugin \
33 xfce4-places-plugin \
34 xfce4-systemload-plugin \
35 xfce4-time-out-plugin \
36 xfce4-timer-plugin \
37 xfce4-embed-plugin \
38 xfce4-weather-plugin \
39 xfce4-fsguard-plugin \
40 xfce4-battery-plugin \
41 xfce4-mount-plugin \
42 xfce4-powermanager-plugin \
43 xfce4-closebutton-plugin \
44 xfce4-equake-plugin \
45 xfce4-notes-plugin \
46 xfce4-whiskermenu-plugin \
47 xfce4-mailwatch-plugin \
48 xfce4-kbdleds-plugin \
49 xfce4-smartbookmark-plugin \
50 xfce4-hotcorner-plugin \
51 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'xfce4-pulseaudio-plugin', '', d)} \
52 xfce4-sensors-plugin \
53 xfce4-calculator-plugin \
54 xfce4-verve-plugin \
55 \
56 xfce-polkit \
57 \
58 thunar-media-tags-plugin \
59 thunar-archive-plugin \
60 \
61 xfce4-appfinder \
62 xfce4-screenshooter \
63 xfce4-power-manager \
64 xfce4-mixer \
65 ristretto \
66 xfce4-taskmanager \
67 gigolo \
68"