blob: 6a2b944be9322904afdd48dc284e1fc3375166e5 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Xfce4 Panel"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
5DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtual/libx11 libxml2 libwnck"
6
7inherit xfce gtk-doc
8
9SRC_URI[md5sum] = "5a333af704e386c90ad829b6baf1a758"
10SRC_URI[sha256sum] = "30920fc2e2fc26279a82b5261a155c2cc15ab2aa1ced2275684a6ff8261b97b0"
11SRC_URI += " \
12 file://0001-Fix-compiler-warning-in-clock-plugin-about-shadowed-.patch \
13 file://0002-clock-time-make-change-of-system-s-timezone-change-t.patch \
14"
15
16EXTRA_OECONF += "--enable-gtk3"
17
18python populate_packages_prepend() {
19 plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
20 plugin_name = d.expand('${PN}-plugin-%s')
21 do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
22 '${PN} plugin for %s', extra_depends='', prepend=True,
23 aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop',
24 '${sysconfdir}/xdg/xfce/panel/%s-*',
25 '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
26 '${bindir}/*%s*'])
27}
28
29PACKAGES_DYNAMIC += "^${PN}-plugin-.*"
30
31PACKAGES =+ "${PN}-gtk3"
32
33FILES_${PN} += "${libdir}/xfce4/panel/migrate \
34 ${libdir}/xfce4/panel/wrapper-1.0"
35
36FILES_${PN}-gtk3 = " \
37 ${libdir}/libxfce4panel-2.0${SOLIBS} \
38 ${libdir}/xfce4/panel/wrapper-2.0 \
39"
40FILES_${PN}-dbg += "${libdir}/xfce4/panel/plugins/.debug \
41"