blob: 03bd205a28ad942d954ab2ddaae175ef492d9e7f [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Meta package adding machine name to known hosts"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
4
5ALLOW_EMPTY_${PN} = "1"
6
7LOCALHOSTMACHINE = "127.0.0.1 ${MACHINE}"
8
9# on some machines starting applications as xfce4-terminal take ages without
10# machine name in hosts
11pkg_postinst_${PN} () {
12if ! grep -q '${LOCALHOSTMACHINE}' $D/etc/hosts ; then
13 echo '${LOCALHOSTMACHINE}' >> $D/etc/hosts
14fi
15}
16
17PACKAGE_ARCH = "${MACHINE_ARCH}"