blob: d5ed04468cc1fb314f8b8131be9951224db6e217 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Xfce4 settings"
2SECTION = "x11/wm"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5DEPENDS = "exo exo-native garcon gtk+ libxfce4util libxfce4ui xfconf dbus-glib libxi virtual/libx11 xrandr libxcursor libxklavier upower"
6
7inherit xfce xfce-git
8
9# schnitzeltony git repo is the mainline repo
10# + datetime-setter - sent to mainline but strange response
11# + minor bugfixes - sent mainline but no response
12# + option to hide mousepointer for a specific (touch) input device - sent mainline but no response
13SRC_URI = " \
14 git://github.com/schnitzeltony/xfce4-settings.git;protocol=git;branch=for-oe-4.12.0-1 \
15 file://0001-xsettings.xml-Set-default-themes.patch \
16"
17SRCREV = "c6683cb2cff489c16c2c7b5eab4017bb461f07f1"
18S = "${WORKDIR}/git"
19PV = "4.12.0+git${SRCPV}"
20
21EXTRA_OECONF += "--enable-maintainer-mode --disable-debug"
22
23PACKAGECONFIG ??= " \
24 ${@bb.utils.contains('DISTRO_FEATURES','systemd','datetime-setter','',d)} \
25 ${@bb.utils.contains('DISTRO_FEATURES','alsa','sound-setter', bb.utils.contains('DISTRO_FEATURES','pulseaudio','sound-setter','',d),d)} \
26"
27PACKAGECONFIG[datetime-setter] = "--enable-datetime-settings, --disable-datetime-settings,, tzdata"
28PACKAGECONFIG[notify] = "--enable-libnotify,--disable-libnotify,libnotify"
29PACKAGECONFIG[sound-setter] = "--enable-sound-settings, --disable-sound-settings, libcanberra, libcanberra-gtk2 sound-theme-freedesktop"
30
31FILES_${PN} += " \
32 ${libdir}/xfce4 \
33 ${datadir}/xfce4 \
34"
35
36RRECOMMENDS_${PN} += "adwaita-icon-theme"
37RRECOMMENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','alsa','libcanberra-alsa','',d)}"
38RRECOMMENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','pulseaudio','libcanberra-pulse','',d)}"