blob: 2d4145ef126aaaa727433001b16dc909fd1cc5d2 [file] [log] [blame]
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05001DESCRIPTION = "The tools for verifying whether a certificate is valid for the intended purposes."
2HOMEPAGE = "https://pypi.org/project/service-identity"
3AUTHOR = "Hynek Schlawack"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=8a0f079f4e6a215d6bd6f9d97cab4d5f"
7
8SRC_URI[md5sum] = "5e5c195d8fcedc72f9068be2ad9b5a13"
9SRC_URI[sha256sum] = "6e6c6086ca271dc11b033d17c3a8bea9f24ebff920c587da090afc9519419d34"
10
11inherit pypi setuptools3 ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
Patrick Williamsb542dec2023-06-09 01:26:37 -050017RDEPENDS:${PN} += " \
18 python3-attr \
19 python3-cryptography \
20 python3-pyasn1-modules \
21"
22
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050023RDEPENDS:${PN}-ptest += " \
24 ${PYTHON_PN}-pytest \
25"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30 cp -rf ${S}/setup.py ${D}${PTEST_PATH}
31}