blob: dd018fb84aa7c4c9d816510d90f43220f57642de [file] [log] [blame]
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05301SUMMARY = "Phosphor Watchdog application"
2DESCRIPTION = "Application that implements software watchdog"
3HOMEPAGE = "http://github.com/openbmc/phosphor-watchdog"
4PR = "r1"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8inherit autotools pkgconfig
9inherit obmc-phosphor-dbus-service
10
11RPROVIDES_${PN} += "virtual/obmc-watchdog"
12PROVIDES += "virtual/obmc-watchdog"
13
14DEPENDS += "autoconf-archive-native"
15DEPENDS += "sdbusplus sdbusplus-native"
16DEPENDS += "phosphor-dbus-interfaces"
17DEPENDS += "phosphor-logging"
18RDEPENDS_${PN} += "libsystemd"
19RDEPENDS_${PN} += "phosphor-logging"
20
21SRC_URI += "git://github.com/openbmc/phosphor-watchdog"
Patrick Williamsdebfbd02017-06-15 08:40:04 -050022SRCREV = "50c30945b8195344da1b38bfc62dcb790f0eb29e"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053023S = "${WORKDIR}/git"
24
25# Copies config file having arguments for host watchdog
26SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/watchdog/poweron"
27
28# Install the override to set up a Conflicts relation
29SYSTEMD_OVERRIDE_${PN} += "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
30
31# For now, watching PowerOn is the only usecase
32OBMC_HOST_WATCHDOG_INSTANCES = "poweron"
33
34# This is really a DBUS service but the service name is
35# an argument, so making it this way.
36WATCHDOG_TMPL = "phosphor-watchdog@.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053037ENABLE_WATCHDOG_TMPL = "obmc-enable-host-watchdog@.service"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053038SYSTEMD_SERVICE_${PN} += "${WATCHDOG_TMPL}"
39
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053040# To Enable Host Watchdog early during poweron
41SYSTEMD_SERVICE_${PN} += "${ENABLE_WATCHDOG_TMPL}"
42
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053043WATCHDOG_TGTFMT = "phosphor-watchdog@{0}.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053044ENABLE_WATCHDOG_TGTFMT = "obmc-enable-host-watchdog@{0}.service"
45
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053046WATCHDOG_FMT = "../${WATCHDOG_TMPL}:obmc-host-start@{1}.target.wants/${WATCHDOG_TGTFMT}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053047ENABLE_WATCHDOG_FMT = "../${ENABLE_WATCHDOG_TMPL}:obmc-host-start@{0}.target.wants/${ENABLE_WATCHDOG_TGTFMT}"
48
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053049SYSTEMD_LINK_${PN} += "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053050SYSTEMD_LINK_${PN} += "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}"