Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Sets up distcc for compilation on the target device" |
| 2 | |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ |
| 5 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 6 | |
| 7 | SRC_URI = "file://distcc.sh" |
| 8 | |
| 9 | S = "${WORKDIR}" |
| 10 | |
| 11 | # Default to the host machine for a running qemu session |
| 12 | DISTCC_HOSTS ?= "192.168.7.1" |
| 13 | |
| 14 | do_configure() { |
| 15 | sed -i "s%@DISTCC_HOSTS@%${DISTCC_HOSTS}%" distcc.sh |
| 16 | } |
| 17 | |
| 18 | do_install() { |
| 19 | install -d ${D}${sysconfdir}/profile.d |
| 20 | install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/ |
| 21 | } |
| 22 | |
| 23 | RDEPENDS_${PN} = "distcc" |