blob: d01b898a9c6439a490c46e12a32e73954e590260 [file] [log] [blame]
Lancelot Kao775cc0a2021-02-22 22:48:15 -06001SUMMARY = "Power Cycle by Hotswap Controller"
2DESCRIPTION = "Power Cycle by Hotswap Controller Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS_${PN} += "bash"
11
12FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
13SRC_URI_append_kudo = " file://hotswap-power-cycle.service"
14
15do_install() {
16 install -d ${D}${systemd_unitdir}/system/
17 install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_unitdir}/system/hotswap-power-cycle.service
18}
19
20SYSTEMD_PACKAGES = "${PN}"
21SYSTEMD_SERVICE_${PN} = " hotswap-power-cycle.service"