Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "An adapter to Linux kernel support for inotify directory-watching." |
| 2 | AUTHOR = "Dustin Oprea" |
| 3 | HOMEPAGE = "https://pypi.org/project/inotify/" |
| 4 | LICENSE = "GPL-2.0-only" |
| 5 | LIC_FILES_CHKSUM = "file://setup.py;md5=79b7ec72aa0d446a552d3cceb5799e41;beginline=28;endline=28" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "974a623a338482b62e16d4eb705fb863ed33ec178680fc3e96ccdf0df6c02a07" |
| 8 | |
| 9 | SRC_URI = " \ |
| 10 | git://github.com/dsoprea/pyinotify.git;branch=master;protocol=https \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | SRCREV = "9be6a51d1660991562eefaaddefa757ca0e0e00f" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit setuptools3 ptest |
| 19 | PIP_INSTALL_PACKAGE = "inotify" |
| 20 | PIP_INSTALL_DIST_PATH = "${S}/dist" |
| 21 | |
| 22 | |
| 23 | RDEPENDS:${PN} += " \ |
| 24 | python3-ctypes \ |
| 25 | python3-logging \ |
| 26 | " |
| 27 | |
| 28 | RDEPENDS:${PN}-ptest += " \ |
| 29 | ${PYTHON_PN}-pytest \ |
| 30 | " |
| 31 | |
| 32 | do_install_ptest() { |
| 33 | install -d ${D}${PTEST_PATH}/tests |
| 34 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 35 | } |