blob: 4ac7c1150033e205ef27fb887fec5d1d66ced837 [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001inherit esw python3native
2
3ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/"
4ESW_COMPONENT_NAME = "libxil.a"
5
6DEPENDS += "dtc-native python3-dtc-native python3-pyyaml-native xilstandalone xilmem device-tree"
7
8do_configure_prepend() {
9 # This will generate CMakeLists.txt which contains
10 # drivers for the libxil
11 cd ${S}
12 #TODO
13 # This call was initially used to get the list of drivers and libraries required
14 # by the design to the build system to use as dependencies to the application
15 # being built, at this point this is all done in a single cmake build bundling
16 # everything in libxil, which is undesired.
17 DRIVERS_LIST=$(nativepython3 ${S}/scripts/getdrvlist.py -d ${DTBFILE})
18}
19
20do_generate_driver_data() {
21 # This script should also not rely on relative paths and such
22 cd ${S}
23 nativepython3 ${S}/scripts/generate_drvdata.py -d ${DTBFILE}
24}
25
26addtask do_generate_driver_data before do_configure after do_prepare_recipe_sysroot
27do_prepare_recipe_sysroot[rdeptask] = "do_unpack"