blob: 6d1fc4b65371e91564d53f34cb46744f5ecc478c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10
11PYPI_PACKAGE = "GitPython"
12
13inherit pypi setuptools3
14
Andrew Geisslerb7d28612020-07-24 16:15:54 -050015SRC_URI[sha256sum] = "2db287d71a284e22e5c2846042d0602465c7434d910406990d5b74df4afb0858"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17DEPENDS += " ${PYTHON_PN}-gitdb"
18
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-gitdb \
22 ${PYTHON_PN}-io \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-math \
25 ${PYTHON_PN}-netclient \
26 ${PYTHON_PN}-stringold \
27 ${PYTHON_PN}-unittest \
28 ${PYTHON_PN}-unixadmin \
29 git \
30"
31
32BBCLASSEXTEND = "native nativesdk"