blob: 452a025fcc42aea5a9b708310ef21b6eded72fd2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Subversion (svn) version control system client"
2HOMEPAGE = "http://subversion.apache.org"
3SECTION = "console/network"
4LICENSE = "Apache-2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6487ae7094d359fa90fb9c4096e52e2b"
6
7DEPENDS = "apr-util serf sqlite3 file lz4"
8DEPENDS_append_class-native = " file-replacement-native"
9
10SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
11 file://disable_macos.patch \
12 file://0001-Fix-libtool-name-in-configure.ac.patch \
13 file://serfmacro.patch \
14 "
15
Andrew Geissler5a43b432020-06-13 10:46:56 -050016SRC_URI[sha256sum] = "6ba8e218f9f97a83a799e58a3c6da1221d034b18d9d8cbbcb6ec52ab11722102"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
Andrew Geissler5a43b432020-06-13 10:46:56 -050018inherit autotools pkgconfig gettext python3native
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20CVE_PRODUCT = "apache:subversion"
21
22PACKAGECONFIG ?= ""
23
24PACKAGECONFIG[boost] = "--with-boost=${RECIPE_SYSROOT}${exec_prefix},--without-boost,boost"
25PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl"
26PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring,--without-gnome-keyring,glib-2.0 gnome-keyring"
27
28EXTRA_OECONF = " \
29 --with-apr=${STAGING_BINDIR_CROSS} \
30 --with-apr-util=${STAGING_BINDIR_CROSS} \
31 --without-apxs \
32 --without-berkeley-db \
33 --without-swig \
34 --disable-keychain \
35 --with-utf8proc=internal \
36 ac_cv_path_RUBY=none \
37"
38
39EXTRA_OEMAKE += "pkgconfig_dir=${libdir}/pkgconfig"
40
41acpaths = "-I build/ -I build/ac-macros/"
42
43CPPFLAGS += "-P"
44BUILD_CPPFLAGS += "-P"
45
46do_configure_prepend () {
47 rm -f ${S}/libtool
48 rm -f ${S}/build/libtool.m4 ${S}/build/ltmain.sh ${S}/build/ltoptions.m4 ${S}/build/ltsugar.m4 ${S}/build/ltversion.m4 ${S}/build/lt~obsolete.m4
49 rm -f ${S}/aclocal.m4
50 sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4
51}
52
53#| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_local/libsvn_ra_local-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| /usr/bin/ld: cannot find -lsvn_delta-1| collect2: ld returned 1 exit status| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_svn/libsvn_ra_svn-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_serf/libsvn_ra_serf-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
54#| x86_64-linux-libtool: install: error: relink `libsvn_ra_serf-1.la' with the above command before installing it
55#| x86_64-linux-libtool: install: warning: `../../subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
56#| /home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/subversion-1.8.9/build-outputs.mk:1090: recipe for target 'install-serf-lib' failed
57#| make: *** [install-serf-lib] Error 1
58PARALLEL_MAKEINST = ""
59
60RDEPENDS_${PN} = "serf"
61
Andrew Geisslerb7d28612020-07-24 16:15:54 -050062BBCLASSEXTEND = "native nativesdk"