Eddie James | b2b7ff6 | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 1 | SUMMARY = "Insecure private key for testing and development" |
| 2 | DESCRIPTION = "Do not use this key to sign images." |
Brad Bishop | 75f0387 | 2018-11-03 09:41:57 -0700 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
Brad Bishop | 6f3f0aa | 2019-09-13 12:14:05 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 5 | PR = "r1" |
| 6 | |
| 7 | SRC_URI += "file://OpenBMC.priv" |
Eddie James | b2b7ff6 | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 8 | |
| 9 | inherit allarch |
| 10 | inherit native |
Eddie James | b2b7ff6 | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 11 | |
Eddie James | b2b7ff6 | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 12 | do_install() { |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 13 | bbplain "Using an insecure image signing key!" |
| 14 | install -d ${D}${datadir} |
| 15 | install -m 400 ${WORKDIR}/OpenBMC.priv ${D}${datadir} |
Eddie James | b2b7ff6 | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 16 | } |