Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "General purpose cryptographic library based on the code from GnuPG" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "A cryptography library developed as a separated module of GnuPG. \ |
| 3 | It can also be used independently of GnuPG, but depends on its error-reporting \ |
| 4 | library Libgpg-error." |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/" |
| 6 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | # helper program gcryptrnd and getrandom are under GPL, rest LGPL |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 10 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & GPL-3.0-or-later" |
| 11 | LICENSE:${PN} = "LGPL-2.1-or-later" |
| 12 | LICENSE:${PN}-dev = "GPL-2.0-or-later & LGPL-2.1-or-later" |
| 13 | LICENSE:dumpsexp-dev = "GPL-3.0-or-later" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 16 | file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \ |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 17 | file://LICENSES;md5=42fa35a25e138166cc40588387f9159d \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 18 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
| 20 | DEPENDS = "libgpg-error" |
| 21 | |
| 22 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 23 | SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 24 | file://0001-libgcrypt-fix-m4-file-for-oe-core.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \ |
| 26 | file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \ |
| 27 | file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 28 | file://0001-Makefile.am-add-a-missing-space.patch \ |
| 29 | " |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 30 | SRC_URI[sha256sum] = "ea849c83a72454e3ed4267697e8ca03390aee972ab421e7df69dfe42b65caaf7" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 32 | # Below whitelisted CVEs are disputed and not affecting crypto libraries for any distro. |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 33 | CVE_CHECK_IGNORE += "CVE-2018-12433 CVE-2018-12438" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 34 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 35 | BINCONFIG = "${bindir}/libgcrypt-config" |
| 36 | |
| 37 | inherit autotools texinfo binconfig-disabled pkgconfig |
| 38 | |
| 39 | EXTRA_OECONF = "--disable-asm" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 41 | |
| 42 | PACKAGECONFIG ??= "capabilities" |
| 43 | PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap" |
| 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | do_configure:prepend () { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 46 | # Else this could be used in preference to the one in aclocal-copy |
| 47 | rm -f ${S}/m4/gpg-error.m4 |
| 48 | } |
| 49 | |
| 50 | # libgcrypt.pc is added locally and thus installed here |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 51 | do_install:append() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 52 | install -d ${D}/${libdir}/pkgconfig |
| 53 | install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/ |
| 54 | } |
| 55 | |
| 56 | PACKAGES =+ "dumpsexp-dev" |
| 57 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 58 | FILES:${PN}-dev += "${bindir}/hmac256" |
| 59 | FILES:dumpsexp-dev += "${bindir}/dumpsexp" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 60 | |
| 61 | BBCLASSEXTEND = "native nativesdk" |