blob: 2922b6a367f90f6e96aa5aef0064a289bd1a0e6a [file] [log] [blame]
Vijay Khemkae810c502019-10-30 10:31:48 -07001SUMMARY = "Chassis Power Control service for Intel based platforms"
2DESCRIPTION = "Chassis Power Control service for Intel based platforms"
3
4SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=ssh"
Andrew Geisslerd3e342f2020-02-13 18:11:47 +00005SRCREV = "e7520ba18a5b5ba6c8eb7a9d543704f9699295a1"
Vijay Khemkae810c502019-10-30 10:31:48 -07006
7PV = "1.0+git${SRCPV}"
8
9S = "${WORKDIR}/git"
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
13
14inherit cmake systemd
15
16SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Chassis.Control.Power.service"
17
18DEPENDS += " \
19 boost \
20 i2c-tools \
21 libgpiod \
22 sdbusplus \
23 phosphor-logging \
24 "