blob: bb0cd1f8a93f69eb0383cda4cc4d3a724dc1b9e2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework"
2LICENSE = "GPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=f1a8bfcbc85304df454b65d378b299c7"
4
5DEPENDS = " \
6 intltool-native \
7 babl \
8 glib-2.0 \
9 pango \
10 cairo \
11 expat \
12 zlib \
13 \
14 json-glib \
15"
16
17GNOMEBASEBUILDCLASS = "meson"
18
19inherit features_check gnomebase vala gobject-introspection
20
21REQUIRED_DISTRO_FEATURES = "x11"
22
23SHPV = "${@gnome_verdir("${PV}")}"
24
25SRC_URI = " \
26 https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz \
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050027 file://0001-Fix-build-with-OpenEXR-3.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050028"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050029SRC_URI[sha256sum] = "c112782cf4096969e23217ccdfabe42284e35d5435ff0c43d40e4c70faeca8dd"
Andrew Geissler82c905d2020-04-13 13:39:40 -050030
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070031PACKAGECONFIG ??= "gexiv2 jpeg libpng libraw librsvg poppler sdl2"
Andrew Geissler82c905d2020-04-13 13:39:40 -050032PACKAGECONFIG_class-native = "libpng librsvg"
33
34PACKAGECONFIG[jasper] = "-Djasper=enabled,-Djasper=disabled,jasper"
35PACKAGECONFIG[gexiv2] = "-Dgexiv2=enabled,-Dgexiv2=disabled,gexiv2"
36PACKAGECONFIG[graphviz] = "-Dgraphviz=enabled,-Dgraphviz=disabled,graphviz"
37PACKAGECONFIG[jpeg] = "-Dlibjpeg=enabled,-Dlibjpeg=disabled,jpeg"
38PACKAGECONFIG[lcms] = "-Dlcms=enabled,-Dlcms=disabled,lcms"
39PACKAGECONFIG[libav] = "-Dlibav=enabled,-Dlibav=disabled,libav"
40PACKAGECONFIG[libpng] = "-Dlibpng=enabled,-Dlibpng=disabled,libpng"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070041PACKAGECONFIG[libraw] = "-Dlibraw=enabled,-Dlibraw=disabled,libraw"
Andrew Geissler82c905d2020-04-13 13:39:40 -050042PACKAGECONFIG[librsvg] = "-Dlibrsvg=enabled,-Dlibrsvg=disabled,librsvg"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070043PACKAGECONFIG[poppler] = "-Dpoppler=enabled,-Dpoppler=disabled,poppler"
Andrew Geissler82c905d2020-04-13 13:39:40 -050044PACKAGECONFIG[sdl] = "-Dsdl1=enabled,-Dsdl1=disabled,virtual/libsdl"
45PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,virtual/libsdl2"
46PACKAGECONFIG[tiff] = "-Dlibtiff=enabled,-Dlibtiff=disabled,tiff"
47PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,webp"
48
49# There are a couple of non-symlink .so files installed into libdir, which need to go into main package
50FILES_${PN} += " \
51 ${libdir}/*.so \
52 ${libdir}/gegl-${SHPV}/*.json \
53 ${libdir}/gegl-${SHPV}/*.so \
54"
55FILES_SOLIBSDEV = "${libdir}/libgegl-${SHPV}${SOLIBSDEV}"
56
57# Fails to build with thumb-1 (qemuarm)
58# gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process':
59# gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275
60ARM_INSTRUCTION_SET = "arm"
61
62BBCLASSEXTEND = "native"