blob: e729d9deb75f0e8f0a0a74c30413a86585aa2c23 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
6
7DEPENDS = " \
Andrew Geissler97771a32021-03-05 15:23:11 -06008 alsa-lib \
9 atk \
10 cairo \
11 fontconfig \
12 freetype \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 gdk-pixbuf-native \
14 intltool-native \
15 libxslt-native \
16 gegl-native \
17 dbus-glib \
18 gtk+ \
19 babl \
20 gegl \
21 libmypaint \
22 mypaint-brushes-1.0 \
23 gexiv2 \
24 jpeg \
Andrew Geissler97771a32021-03-05 15:23:11 -060025 libmng \
Andrew Geissler82c905d2020-04-13 13:39:40 -050026 libpng \
27 libexif \
28 tiff \
29 lcms \
30 poppler \
31 poppler-data \
32 jasper \
33 bzip2 \
34 libgudev \
35 libmng \
36 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \
37"
38DEPENDS_append_libc-musl = " libexecinfo"
39
40inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg
41
42REQUIRED_DISTRO_FEATURES = "x11"
43
44SHPV = "${@gnome_verdir("${PV}")}"
45
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070046SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2"
47SRC_URI[sha256sum] = "bd1bb762368c0dd3175cf05006812dd676949c3707e21f4e6857435cb435989e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050048
49EXTRA_OECONF = "--disable-python \
50 --without-webkit \
Andrew Geissler97771a32021-03-05 15:23:11 -060051 --disable-check-update \
Andrew Geissler82c905d2020-04-13 13:39:40 -050052 --without-wmf"
53
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050054EXTRA_OECONF_append_mipsarch = " --disable-vector-icons"
Andrew Geissler32b11992021-03-31 13:37:05 -050055EXTRA_OECONF_append_libc-musl_riscv32 = " --disable-vector-icons"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050056EXTRA_OECONF_append_libc-musl_x86 = " --disable-vector-icons"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070057EXTRA_OECONF_append_toolchain-clang_arm = " --disable-vector-icons"
Andrew Geissler82c905d2020-04-13 13:39:40 -050058
59do_configure_append() {
60 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
61 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
62}
63
64do_compile_prepend() {
65 # Let native babl/gegl find their plugins
66 export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'`
67 export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'`
68}
69
70FILES_${PN} += "${datadir}/metainfo"
71
72RDEPENDS_${PN} += "mypaint-brushes-1.0"