blob: 828c21cf9f3f5cdf29b649996e3ebc8dc54354bd [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Trace and analyze execution of a program written in C/C++"
2HOMEPAGE = "https://github.com/namhyung/uftrace"
3BUGTRACKER = "https://github.com/namhyung/uftrace/issues"
4SECTION = "devel"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8DEPENDS = "elfutils"
9DEPENDS_append_libc-musl = " argp-standalone"
10
11inherit autotools
12
Andrew Geissler2ee498a2020-05-29 15:52:06 -050013PV .= "+git${SRCPV}"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070014SRCREV = "a5e5a51d32bdfe59af8b453ca08d78cbdf0b3c61"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015SRC_URI = "git://github.com/namhyung/${BPN} \
16 "
17S = "${WORKDIR}/git"
18
Andrew Geissler82c905d2020-04-13 13:39:40 -050019LDFLAGS_append_libc-musl = " -largp"
20
21def set_target_arch(d):
22 import re
23 arch = d.getVar('TARGET_ARCH')
24 if re.match(r'i.86', arch, re.I):
25 return 'i386'
26 elif re.match('armeb', arch, re.I):
27 return 'arm'
28 else:
29 return arch
30
31EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \
32 with_elfutils=/use/libelf/from/sysroot"
33
34do_configure() {
35 ${S}/configure ${EXTRA_UFTRACE_OECONF}
36}
37
38FILES_SOLIBSDEV = ""
39FILES_${PN} += "${libdir}/*.so"
40
41COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)"
42
43# uftrace supports armv6 and above
44COMPATIBLE_HOST_armv4 = 'null'
45COMPATIBLE_HOST_armv5 = 'null'