blob: 53ebf7b6a5e6de1b14924c56b39ac4ef5097c78d [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001DESCRIPTION = "PDF transformation/inspection software"
2HOMEPAGE = "http://qpdf.sourceforge.net"
3LICENSE = "Artistic-2.0"
4SECTION = "libs"
5DEPENDS = "libpcre zlib libjpeg-turbo"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf/qpdf-${PV}.tar.gz"
8
9LIC_FILES_CHKSUM = "file://Artistic-2.0;md5=7806296b9fae874361e6fb10072b7ee3"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070010SRC_URI[sha256sum] = "062808c40ef8741ec8160ae00168638a712cfa1d4bf673e8e595ab5eba1da947"
Brad Bishope42b3e32020-01-15 22:08:42 -050011
12inherit autotools-brokensep gettext
13
14# disable random file detection for cross-compile
15EXTRA_OECONF = "--without-random \
16 --disable-static \
17 --disable-check-autofiles \
18 "
19
20EXTRA_OEMAKE_class-target = "LIBTOOL=${HOST_SYS}-libtool"
21
Andrew Geissler7f40b712020-05-15 14:09:53 -050022LDFLAGS_append_mipsarch = " -latomic"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060023LDFLAGS_append_riscv32 = " -latomic"
Andrew Geissler7f40b712020-05-15 14:09:53 -050024
Brad Bishope42b3e32020-01-15 22:08:42 -050025S="${WORKDIR}/${BPN}-${PV}"
26
27# avoid Makefile returning error on 'make clean' before configure was run
28CLEANBROKEN = "1"
29
30DEBIAN_NOAUTONAME_libqpdf = "1"
31
32PACKAGES =+ "libqpdf"
33FILES_libqpdf = "${libdir}/libqpdf.so.*"
34
Andrew Geisslereafcbb82020-06-05 17:59:17 -050035RDEPENDS_${PN} = "libqpdf"