blob: e6b196956ed49f6898235e85c3911e760fbd9828 [file] [log] [blame]
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07001SUMMARY = "Python 2 and 3 compatibility library"
2HOMEPAGE = "https://xlsxwriter.readthedocs.io"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4e95e368cd6cb090815046688e92d11e"
6
7inherit pypi setuptools3
8
9PYPI_PACKAGE = "XlsxWriter"
10
11RDEPENDS_${PN} += " \
12 python3-crypt \
13 python3-datetime \
14 python3-compression \
15 python3-numbers \
16 python3-io \
17"
18
19SRC_URI[sha256sum] = "641db6e7b4f4982fd407a3f372f45b878766098250d26963e95e50121168cbe2"
20
21BBCLASSEXTEND = "native nativesdk"