blob: f9d9a9e47193205a1e5870b1f4f0d09e85de3724 [file] [log] [blame]
SpencerKu67f272f2020-03-24 16:18:14 +08001SUMMARY = "Hotswap Controller Setting Changing"
2DESCRIPTION = "Hotswap Controller Setting Changing Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS_${PN} += "bash"
11
12FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
13SRC_URI_append = " file://gsj-hotswap-change-setting.sh \
14 file://gsj-hotswap-change-setting.service \
15 "
16
17do_install() {
18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/gsj-hotswap-change-setting.sh ${D}${bindir}/
20
21 install -d ${D}${systemd_unitdir}/system/
22 install -m 0644 ${WORKDIR}/gsj-hotswap-change-setting.service ${D}${systemd_unitdir}/system
23}
24
25SYSTEMD_PACKAGES = "${PN}"
26SYSTEMD_SERVICE_${PN} = "gsj-hotswap-change-setting.service"