blob: d006ae76362a070b1d115706f6751faf780343d7 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Paho MQTT - C libraries for the MQTT and MQTT-SN protocols"
2DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)."
3HOMEPAGE = "http://www.eclipse.org/paho/"
4SECTION = "console/network"
5LICENSE = "EPL-2.0 | EDL-1.0"
6
7LIC_FILES_CHKSUM = " \
8 file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \
9 file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \
10 file://notice.html;md5=943f861069889acecebf51dfa24478e2 \
11 file://about.html;md5=e5662cbb5f8fd5c9faac526e4077898e \
12"
13
14SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http;branch=master;protocol=https"
15
16SRCREV = "4157a27d39f1dd5b95750ecb6acd1481432785d8"
17
18DEPENDS = "openssl"
19
20S = "${WORKDIR}/git"
21
22inherit cmake
23
24do_configure:prepend() {
25 sed -i s:\ lib/cmake:\ ${baselib}/cmake:g ${S}/src/CMakeLists.txt
26}
27
28do_install:append() {
29 # paho-mqtt installes some thing that we don't want.
30 rm -rf ${D}${prefix}/samples
31 find ${D}${prefix} -maxdepth 1 -type f -delete
32}
33
34EXTRA_OECMAKE = "-DPAHO_WITH_SSL=ON"