blob: 61e53029b31472803595a8ca861fd105b91aac4d [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "libnvdimm utility library"
2DESCRIPTION = "Utility library for managing the libnvdimm \
3(non-volatile memory device) sub-system in the Linux kernel. \
4The LIBNVDIMM subsystem provides support for three types of \
5NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \
6simultaneously support both PMEM and BLK mode access."
7HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e66651809cac5da60c8b80e9e4e79e08"
10
11inherit autotools-brokensep pkgconfig bash-completion systemd
12
13SRCREV = "cb2d678dd6d286dd96d31548c32449a8b883ae32"
14SRC_URI = "git://github.com/pmem/ndctl.git"
15
16DEPENDS = "virtual/kernel kmod udev json-c"
17
18S = "${WORKDIR}/git"
19
20EXTRA_OECONF += "--enable-test --enable-destructive --disable-docs"
21
Brad Bishopba6de432019-05-21 08:07:33 -040022# Depends on MACHINE_ARCH kernel
23PACKAGE_ARCH = "${MACHINE_ARCH}"
24
Brad Bishop19323692019-04-05 15:28:33 -040025PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
26PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd"
27
28do_configure_prepend() {
29 ${S}/autogen.sh
30}
31
32SYSTEMD_SERVICE_${PN} = "ndctl-monitor.service"
33SYSTEMD_AUTO_ENABLE_${PN} = "disable"