blob: ca88023d9bded9977c15ef77257bf89e7bb9783c [file] [log] [blame]
Brad Bishop2ad7ce32017-07-09 23:41:49 -04001SUMMARY = "Phosphor Mapper Configuration"
2DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \
3configuration files to the native /usr/share/phosphor-mapper filesystem."
4HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
5PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07006LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04007LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Brad Bishop2ad7ce32017-07-09 23:41:49 -04008
Brad Bishop2ad7ce32017-07-09 23:41:49 -04009inherit phosphor-mapper
Joseph Reynolds79809ea2021-02-26 15:37:31 -060010inherit native
Brad Bishop2ad7ce32017-07-09 23:41:49 -040011
12PHOSPHOR_MAPPER_CONFIGS = " \
13 phosphor-dbus-interfaces-mapper-config-native \
14 phosphor-legacy-namespace-mapper-config-native \
15 "
16
17DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}"
18
19# To add namespaces and blacklists to the mapper configuration,
20# create a native recipe in your layer, and add it to
21# PHOSPHOR_MAPPER_CONFIGS with a bbappend to this recipe.
22# Recipes should set one of the variables below.
23# Consult phosphor-mapper.bbclass for additional information.
24
Brad Bishop4f045d02018-10-22 20:48:49 -040025# Add services to be monitored.
26PHOSPHOR_MAPPER_SERVICE = ""
27
Brad Bishop2ad7ce32017-07-09 23:41:49 -040028# Add interfaces to be monitored.
29PHOSPHOR_MAPPER_INTERFACE = ""
30
Brad Bishop4f045d02018-10-22 20:48:49 -040031# Blacklist services from being monitored.
32PHOSPHOR_MAPPER_SERVICE_BLACKLIST = ""
33
Brad Bishop2ad7ce32017-07-09 23:41:49 -040034do_install() {
35 install -d ${D}/${namespace_dir}
36 install -d ${D}/${interface_dir}
Brad Bishop4f045d02018-10-22 20:48:49 -040037 install -d ${D}/${serviceblacklist_dir}
Brad Bishop2ad7ce32017-07-09 23:41:49 -040038}