blob: 6941ae8b3312aaa0db7270235b6f333d5753d072 [file] [log] [blame]
Ed Tanous760881a2017-11-02 12:58:57 -07001# This recipe requires online access to build, as it uses NPM for dependency
2# management and resolution.
Patrick Venturee28f3872018-10-03 13:22:12 -07003PR = "r1"
4PV = "1.0+git${SRCPV}"
Ed Tanous760881a2017-11-02 12:58:57 -07005LICENSE = "Apache-2.0"
Ed Tanous760881a2017-11-02 12:58:57 -07006LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venturee28f3872018-10-03 13:22:12 -07007
Patrick Williamsbb99d222022-01-24 15:55:09 -06008SRC_URI = "git://github.com/openbmc/phosphor-webui.git;branch=master;protocol=https"
Andrew Geisslerf1429ef2022-08-04 11:51:00 -05009SRCREV = "e16bb5c35893591eab048ae4ef646a9e5e2f7e94"
Ed Tanous760881a2017-11-02 12:58:57 -070010S = "${WORKDIR}/git"
11
Patrick Williams12fc9392021-08-06 09:16:53 -050012DEPENDS:prepend = "nodejs-native "
Ed Tanous760881a2017-11-02 12:58:57 -070013
Ed Tanous760881a2017-11-02 12:58:57 -070014inherit allarch
15
Patrick Williams12fc9392021-08-06 09:16:53 -050016FILES:${PN} += "${datadir}/www/*"
Ed Tanous760881a2017-11-02 12:58:57 -070017
18do_compile () {
Ed Tanous065ecd62022-06-09 11:33:48 -070019 bbwarn "phosphor-webui is deprecated and has been replaced with webui-vue"
Ed Tanous760881a2017-11-02 12:58:57 -070020 cd ${S}
21 rm -rf node_modules
Jeremy Kerr31ea32d2019-05-31 09:38:04 +080022 npm --loglevel info --proxy=${http_proxy} --https-proxy=${https_proxy} install
Ed Tanous760881a2017-11-02 12:58:57 -070023 npm run-script build
24}
25
26do_install () {
27 # create directory structure
28 install -d ${D}${datadir}/www
29 cp -r ${S}/dist/** ${D}${datadir}/www
30 find ${D}${datadir}/www -type f -exec chmod a=r,u+w '{}' +
31 find ${D}${datadir}/www -type d -exec chmod a=rx,u+w '{}' +
32}
33