blob: 536079fc7555c5eb10c59dca1d71018d8f2e7a88 [file] [log] [blame]
Lancelot Kaoc2c04b02021-02-22 22:55:06 -06001SUMMARY = "foxconn OEM IPMI commands"
2DESCRIPTION = "foxconn OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7S = "${WORKDIR}/git"
8
9DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod"
10
11inherit cmake obmc-phosphor-ipmiprovider-symlink
12
13EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
14
15LIBRARY_NAMES = "libfiioemcmds.so"
16
Patrick Williamsbb99d222022-01-24 15:55:09 -060017SRC_URI = "git://github.com/openbmc/foxconn-ipmi-oem.git;branch=master;protocol=https"
Andrew Geisslerd4100a52021-11-18 23:30:19 +000018SRCREV = "da2cf0d2b0f4cd56bc93575a435a5ee1c848f7b0"
Lancelot Kaoc2c04b02021-02-22 22:55:06 -060019
20HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
21NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
22
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050023FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
24FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
25FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
26FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"