blob: edaee1b022ddfbb055b42feb878464a372bf3fcf [file] [log] [blame]
Patrick Venture19d20502018-10-24 11:10:32 -07001SUMMARY = "Google i2c OEM commands"
2DESCRIPTION = "Google i2c OEM commands"
3HOMEPAGE = "https://github.com/openbmc/google-ipmi-i2c"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-host"
14
15S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060016SRC_URI = "git://github.com/openbmc/google-ipmi-i2c;branch=master;protocol=https"
Andrew Geissler3039e732021-10-25 08:50:15 +000017SRCREV = "d78cbec9efb29526d913cc02d61e0b9bf5cff5ae"
Patrick Venture19d20502018-10-24 11:10:32 -070018
Willy Tu4dd03ca2021-08-06 09:37:35 -070019FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
20FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
21FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
22FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venture19d20502018-10-24 11:10:32 -070023
24HOSTIPMI_PROVIDER_LIBRARY += "libi2ccmds.so"