blob: b0db682c4e9db31079aa79280c121ad23544e952 [file] [log] [blame]
Benjamin Fairfbf258a2019-10-21 18:45:41 -07001SUMMARY = "Image Generation and Programming Scripts for NPCM7XX (Poleg) devices"
2DESCRIPTION = "Image Generation and Programming Scripts for NPCM7XX (Poleg) devices"
3HOMEPAGE = "https://github.com/Nuvoton-Israel/igps"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = " \
Patrick Williamsbb99d222022-01-24 15:55:09 -06008 git://github.com/Nuvoton-Israel/igps;branch=master;protocol=https \
Benjamin Fairfbf258a2019-10-21 18:45:41 -07009 file://0001-Adjust-paths-for-use-with-Bitbake.patch \
10"
11# tag IGPS_02.01.12
12SRCREV = "2fb1a3b0d61164ed1157e27889a4ec2292cbc760"
13
14S = "${WORKDIR}/git"
15
16DEST = "${D}${datadir}/${BPN}"
17
18do_install() {
19 install -d ${DEST}
20 install ImageGeneration/references/BootBlockAndHeader_${IGPS_MACHINE}.xml ${DEST}
21 install ImageGeneration/references/UbootHeader_${IGPS_MACHINE}.xml ${DEST}
22 install ImageGeneration/inputs/mergedBootBlockAndUboot.xml ${DEST}
23}
24
25inherit native