blob: 6cf09350d9ac20457d6bc6528962b374a7486c9e [file] [log] [blame]
Adriana Kobylak2fae8ec2018-09-24 14:27:15 -05001SUMMARY = "Network Block Device Proxy"
2HOMEPAGE = "https://github.com/openbmc/jsnbd"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8inherit autotools pkgconfig
9
10DEPENDS += "json-c"
11DEPENDS += "udev"
12
Patrick Williams12fc9392021-08-06 09:16:53 -050013RDEPENDS:${PN} += "nbd-client"
Adriana Kobylak723136d2018-10-03 15:16:29 -050014
Adriana Kobylak2fae8ec2018-09-24 14:27:15 -050015S = "${WORKDIR}/git"
16
Patrick Williamsbb99d222022-01-24 15:55:09 -060017SRC_URI = "git://github.com/openbmc/jsnbd;branch=master;protocol=https"
Andrew Geisslerb2afe3b2021-10-27 23:50:29 +000018SRCREV = "7b7c29369cfeb267efa7f45b271aca6910687461"
Adriana Kobylak329a8052018-10-24 13:31:40 -050019
20NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"
21
Patrick Williams12fc9392021-08-06 09:16:53 -050022do_install:append() {
Adriana Kobylak329a8052018-10-24 13:31:40 -050023 install -d ${D}${sysconfdir}/nbd-proxy/
24 install -m 0644 ${NBD_PROXY_CONFIG_JSON} ${D}${sysconfdir}/nbd-proxy/config.json
25}