blob: e08859c77b8426242ce85f4dcd1404b12952f66c [file] [log] [blame]
Xo Wang4ef18bf2016-10-24 18:44:49 -07001DESCRIPTION = "Command line tools for hardware device registers"
Patrick Venture75072092017-10-05 15:11:30 -07002HOMEPAGE = "https://github.com/jonmayergoogle/iotools"
Xo Wang4ef18bf2016-10-24 18:44:49 -07003LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
Brad Bishop3a3497c2018-03-30 12:27:37 -04005SRCREV = "8d928b3360246b8ead95b442ca3887ce8b8f942f"
Patrick Williamsbb99d222022-01-24 15:55:09 -06006SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https;branch=master"
Xo Wang4ef18bf2016-10-24 18:44:49 -07007PV = "v1.6+git${SRCPV}"
8
Patrick Venturef5952ed2017-10-05 16:25:40 -07009inherit obmc-phosphor-systemd
10
Xo Wang4ef18bf2016-10-24 18:44:49 -070011S = "${WORKDIR}/git"
Patrick Williams12fc9392021-08-06 09:16:53 -050012FILES:${PN} = "${sbindir}"
Xo Wang4ef18bf2016-10-24 18:44:49 -070013
14do_compile() {
15 # CC is overridden in the Makefile, so override it harder in the invocation
16 oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0
17}
18
19# The "install" make target runs the binary to create links for subcommands.
20# The links are excessive and this doesn't work for cross compiling.
21do_install() {
22 install -d ${D}${sbindir}
23 install -m 0755 iotools ${D}${sbindir}
24}
Patrick Venturef5952ed2017-10-05 16:25:40 -070025
Patrick Williams12fc9392021-08-06 09:16:53 -050026SYSTEMD_SERVICE:${PN} += "iotools-setup.service"