blob: d2df636d4536760ffab8b028e7b5b68034ed2e63 [file] [log] [blame]
Brad Bishop0e04b2e2019-05-13 13:45:49 -04001# Provides the config file for the phosphor-fan-presence application.
2# The default config file is empty. To provide a real one,
3# append this recipe in a layer, add:
Patrick Williams12fc9392021-08-06 09:16:53 -05004# FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
Brad Bishop0e04b2e2019-05-13 13:45:49 -04005# and provide a config file.
6
7SUMMARY = "Config file for phosphor-fan-presence"
8PR = "r1"
9LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -040010LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Brad Bishop0e04b2e2019-05-13 13:45:49 -040011
12inherit allarch
13inherit phosphor-fan
14
15S = "${WORKDIR}"
16PROVIDES += "virtual/phosphor-fan-presence-config"
17
18SRC_URI = "file://config.yaml"
19
20do_install() {
21 install -D config.yaml ${D}${presence_datadir}/config.yaml
22}
23
Patrick Williams12fc9392021-08-06 09:16:53 -050024FILES:${PN} += "${presence_datadir}/config.yaml"