blob: aa0e80798b15c40c530edcce94d54633655b04fd [file] [log] [blame]
Brad Bishop0e04b2e2019-05-13 13:45:49 -04001SUMMARY = "Generate fan presence YAML from the MRW"
2PR = "r1"
3LICENSE = "Apache-2.0"
4
5inherit allarch
6inherit phosphor-fan
7inherit mrw-xml
8
9DEPENDS = "mrw-native mrw-perl-tools-native"
10PROVIDES += "virtual/phosphor-fan-presence-config"
11
Patrick Williams12fc9392021-08-06 09:16:53 -050012FILES:${PN} += "${presence_datadir}/config.yaml"
Brad Bishop0e04b2e2019-05-13 13:45:49 -040013
14S = "${WORKDIR}"
15
16do_install() {
17 DEST=${D}${presence_datadir}
18 install -d ${DEST}
19
20 ${bindir}/perl-native/perl \
21 ${bindir}/gen_presence_yaml.pl \
22 -i ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} \
23 -o ${DEST}/config.yaml
24}