blob: 5615bf374c6e9133388603f6ae15778ef61a2e76 [file] [log] [blame]
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05301SUMMARY = "Phosphor GPIO monitor application"
2DESCRIPTION = "Application to monitor gpio assertions"
3HOMEPAGE = "http://github.com/openbmc/phosphor-gpio-monitor"
4PR = "r1"
Patrick Venture7e32f4c2018-10-21 08:24:24 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Brad Bishop28095f12019-10-29 15:12:15 -04008inherit meson pkgconfig
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05309inherit obmc-phosphor-dbus-service
10
Gunnar Millsb163e9b2017-07-10 15:49:43 -050011GPIO_PACKAGES = " \
12 ${PN}-monitor \
13 ${PN}-presence \
14"
15
Brad Bishop2083f662018-04-11 11:42:57 -040016PACKAGE_BEFORE_PN += "${GPIO_PACKAGES}"
Patrick Williams12fc9392021-08-06 09:16:53 -050017ALLOW_EMPTY:${PN} = "1"
Gunnar Millsb163e9b2017-07-10 15:49:43 -050018SYSTEMD_PACKAGES = "${GPIO_PACKAGES}"
19
Patrick Williams12fc9392021-08-06 09:16:53 -050020RPROVIDES:${PN}-monitor += "virtual/obmc-gpio-monitor"
21RPROVIDES:${PN}-presence += "virtual/obmc-gpio-presence"
Gunnar Millsb163e9b2017-07-10 15:49:43 -050022
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053023PROVIDES += "virtual/obmc-gpio-monitor"
Gunnar Millsb163e9b2017-07-10 15:49:43 -050024PROVIDES += "virtual/obmc-gpio-presence"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053025
Patrick Williams4b32c9a2020-03-31 16:43:15 -050026DEPENDS += "sdbusplus"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053027DEPENDS += "phosphor-dbus-interfaces"
Patrick Williams158f5f52017-06-08 08:48:06 -050028DEPENDS += "libevdev"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053029DEPENDS += "phosphor-logging"
Brad Bishop44f3cce2019-03-22 23:41:42 -040030DEPENDS += "systemd"
Vijay Khemka6890d302019-10-18 18:21:27 -070031DEPENDS += "boost"
32DEPENDS += "libgpiod"
33DEPENDS += "cli11"
34DEPENDS += "nlohmann-json"
Gunnar Millsb163e9b2017-07-10 15:49:43 -050035
Patrick Williams12fc9392021-08-06 09:16:53 -050036SYSTEMD_SERVICE:${PN}-monitor += "phosphor-multi-gpio-monitor.service"
37SYSTEMD_SERVICE:${PN}-monitor += "phosphor-gpio-monitor@.service"
38SYSTEMD_SERVICE:${PN}-presence += "phosphor-gpio-presence@.service"
Gunnar Millsb163e9b2017-07-10 15:49:43 -050039
Patrick Williams12fc9392021-08-06 09:16:53 -050040FILES:${PN}-monitor += "${bindir}/phosphor-gpio-monitor"
41FILES:${PN}-monitor += "${bindir}/phosphor-multi-gpio-monitor"
42FILES:${PN}-monitor += "${bindir}/phosphor-gpio-util"
Anton Blanchard782d7192021-08-16 23:51:27 -060043FILES:${PN}-monitor += "${nonarch_base_libdir}/udev/rules.d/99-gpio-keys.rules"
Patrick Williams12fc9392021-08-06 09:16:53 -050044FILES:${PN}-presence += "${bindir}/phosphor-gpio-presence"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053045
Patrick Williamsbb99d222022-01-24 15:55:09 -060046SRC_URI += "git://github.com/openbmc/phosphor-gpio-monitor;branch=master;protocol=https"
Andrew Geissler9a38f142021-10-26 13:21:15 +000047SRCREV = "c4b6ce728089737ad85ab5cfa7f34e2a912f091b"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053048S = "${WORKDIR}/git"
William A. Kennington III626c2cf2021-06-04 18:08:38 -070049
Patrick Williamsed104d42021-08-31 13:19:27 -050050EXTRA_OEMESON:append = " -Dtests=disabled"