blob: cc84a9bd90172c7052f1bab9dc9187534c52d633 [file] [log] [blame]
Kun Yi733887b2019-03-08 11:43:27 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs-binarystore"
2SUMMARY = "BMC Generic Binary Blob Store via OEM IPMI Blob Transport"
3DESCRIPTION = "This package provides a read/write/serialize abstraction for storing binary data through IPMI blobs"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-blobs"
14DEPENDS += "phosphor-logging"
15DEPENDS += "protobuf-native"
16DEPENDS += "protobuf"
17
Andrew Geissler95816502021-11-17 23:20:48 +000018PACKAGECONFIG ??= ""
19PACKAGECONFIG[blobtool] = ",--disable-blobtool"
20
Kun Yi733887b2019-03-08 11:43:27 -080021S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060022SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs-binarystore;branch=master;protocol=https"
Andrew Geisslerc6621272021-11-24 00:30:55 +000023SRCREV = "a21027dcb1a0396e57347ab1066821c4d8ba30b2"
Kun Yi733887b2019-03-08 11:43:27 -080024
Patrick Williams12fc9392021-08-06 09:16:53 -050025FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
26FILES:${PN}:append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
27FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Kun Yi733887b2019-03-08 11:43:27 -080028
29BLOBIPMI_PROVIDER_LIBRARY += "libbinarystore.so"