blob: 253652d6dc5282d3a9c102982322919be4f724e8 [file] [log] [blame]
Lei YU5422b0a2019-12-23 15:41:17 +08001HOMEPAGE = "https://github.com/openbmc/phosphor-psu-code-mgmt"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Williamsbb99d222022-01-24 15:55:09 -06004SRC_URI += "git://github.com/openbmc/phosphor-psu-code-mgmt;branch=master;protocol=https"
Andrew Geisslerf7a8ed62021-11-02 05:51:05 +00005SRCREV = "95ad4ee2854fb926d0495df3fb0a12e0874e6c71"
Lei YU5422b0a2019-12-23 15:41:17 +08006SUMMARY = "Phosphor PSU software manager"
7DESCRIPTION = "Providing PSU firmware version and upgrade"
8
9PR = "r1"
10PV = "1.0+git${SRCPV}"
11
12inherit meson
13inherit pkgconfig
14inherit obmc-phosphor-systemd
15
16S = "${WORKDIR}/git"
17
18DEPENDS = " \
19 phosphor-logging \
20 phosphor-dbus-interfaces \
21 sdbusplus \
22 openssl \
23 "
24
25# The default config of this repo depends on utils from phosphor-power.
26# If your system does not depend on phosphor-power, please use
Patrick Williams12fc9392021-08-06 09:16:53 -050027# RDEPENDS:${PN}:remove to remove the dependency.
28RDEPENDS:${PN} += "phosphor-power"
Lei YU5422b0a2019-12-23 15:41:17 +080029
30# The below configs are expected to be overriden by machine layer
31
32## The psutils here comes from phosphor-power repo where
33## * PSU_VERSION_UTIL accepts a PSU inventory path and returns the PSU
34## firmware version string
35## * PSU_VERSION_COMPARE_UTIL accepts several PSU inventory paths and return
36## the newest version string
37PSU_VERSION_UTIL ?= "-DPSU_VERSION_UTIL='/usr/bin/psutils --raw --get-version'"
38PSU_VERSION_COMPARE_UTIL ?= "-DPSU_VERSION_COMPARE_UTIL='/usr/bin/psutils --raw --compare'"
39
40## The psu-update@.service from repo is an example service that only prints a log and fails
41## Override it in a machine layer to invoke the psu update util
42PSU_UPDATE_SERVICE ?= "-DPSU_UPDATE_SERVICE=psu-update@.service"
43
44EXTRA_OEMESON = " \
45 -Dtests=disabled \
46 ${PSU_VERSION_UTIL} \
47 ${PSU_VERSION_COMPARE_UTIL} \
48 ${PSU_UPDATE_SERVICE} \
49 "
50
Patrick Williams12fc9392021-08-06 09:16:53 -050051SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.Software.Psu.Updater.service"
52SYSTEMD_SERVICE:${PN} += "psu-update@.service"