blob: fa2832f00e7d1bb89ee7572430ffb1fcec6b7441 [file] [log] [blame]
Jason M. Billsc8659172018-10-26 14:07:48 -07001SUMMARY = "Journal IPMI SEL Logger"
2DESCRIPTION = "Utility to write IPMI SEL records to the journal"
3
4# SEL Logger has the ability to monitor and automatically log SEL records for
5# various types of events, but this is disabled by default. The following
6# flags can be set in a .bbappend to enable specific types of event
7# monitoring:
8#
9# SEL_LOGGER_MONITOR_THRESHOLD_EVENTS:
10# Monitors and logs SEL records for threshold sensor events
11
Andrew Geisslerec34cc62021-11-03 09:57:52 -050012inherit pkgconfig meson systemd
Brad Bishopd8b59672020-10-27 09:22:51 -040013S = "${WORKDIR}/git"
Jason M. Billsc8659172018-10-26 14:07:48 -070014
15LICENSE = "Apache-2.0"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
17
William A. Kennington IIIc9851952021-07-29 17:57:30 -070018DEPENDS += " \
19 boost \
20 sdbusplus \
21 systemd \
William A. Kennington IIIc9851952021-07-29 17:57:30 -070022 "
Jason M. Billsc8659172018-10-26 14:07:48 -070023
Patrick Williamsbb99d222022-01-24 15:55:09 -060024SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=https;branch=master"
Andrew Geisslerf340bac2021-10-26 04:31:49 +000025SRCREV = "87e3fcf439f2b943272365e1d294984f39bb52b8"
Jason M. Billsc8659172018-10-26 14:07:48 -070026
27PV = "0.1+git${SRCPV}"
28
Patrick Williams12fc9392021-08-06 09:16:53 -050029SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Logging.IPMI.service"
William A. Kennington IIIc9851952021-07-29 17:57:30 -070030
31PACKAGECONFIG ??= ""
William A. Kennington IIIe5b39f62021-08-06 09:23:57 -070032PACKAGECONFIG[log-threshold] = "-Dlog-threshold=true,-Dlog-threshold=false,"
33PACKAGECONFIG[log-pulse] = "-Dlog-pulse=true,-Dlog-pulse=false,"
34PACKAGECONFIG[log-watchdog] = "-Dlog-watchdog=true,-Dlog-watchdog=false,"
35PACKAGECONFIG[log-alarm] = "-Dlog-alarm=true,-Dlog-alarm=false,"
36PACKAGECONFIG[send-to-logger] = "-Dsend-to-logger=true,-Dsend-to-logger=false,phosphor-logging"
Charles Boyer40e6cb62021-09-09 09:28:08 -050037PACKAGECONFIG[clears-sel] = "-Dclears-sel=true,-Dclears-sel=false"