blob: f88cb3d27a46f1403cb31925caf92ecb8fed605f [file] [log] [blame]
Benjamin Fair526724c2020-04-10 13:01:48 -07001SUMMARY = "NVMe Drive Manager"
2DESCRIPTION = "Daemon to monitor and report the status of NVMe drives"
3HOMEPAGE = "https://github.com/openbmc/phosphor-nvme"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8inherit meson pkgconfig
9inherit systemd
10
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "sdeventplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "nlohmann-json"
16
Patrick Williamsbb99d222022-01-24 15:55:09 -060017SRC_URI = "git://github.com/openbmc/phosphor-nvme.git;protocol=https;branch=master"
Andrew Geisslerd2217202021-10-25 16:51:31 +000018SRCREV = "5022a4ee5cd4d3eaeabc4e991507e71b35b26a16"
Benjamin Fair526724c2020-04-10 13:01:48 -070019S = "${WORKDIR}/git"
20
Patrick Williams12fc9392021-08-06 09:16:53 -050021SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.nvme.manager.service"