blob: 472ae9284036c28500114563de63b034d883144d [file] [log] [blame]
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05301SUMMARY = "Phosphor User Manager Daemon"
2DESCRIPTION = "Daemon that does user management"
3HOMEPAGE = "http://github.com/openbmc/phosphor-user-manager"
4PR = "r1"
Patrick Venture4f792732018-10-02 20:51:15 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venture4f792732018-10-02 20:51:15 -07008
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05309inherit autotools pkgconfig
10inherit obmc-phosphor-dbus-service
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbusplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "phosphor-dbus-interfaces"
Tom Joseph926556d2018-07-10 12:23:06 -050016DEPENDS += "boost"
Andrew Geissler1de95de2018-10-09 04:10:28 +000017DEPENDS += "nss-pam-ldapd"
Brad Bishop44f3cce2019-03-22 23:41:42 -040018DEPENDS += "systemd"
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050019PACKAGE_BEFORE_PN = "phosphor-ldap"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053020
Richard Marian Thomaiyara3488602018-04-12 16:06:36 -070021inherit useradd
22
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050023USERADD_PACKAGES = "${PN} phosphor-ldap"
24DBUS_PACKAGES = "${USERADD_PACKAGES}"
Richard Marian Thomaiyara3488602018-04-12 16:06:36 -070025# add groups needed for privilege maintenance
Patrick Williams12fc9392021-08-06 09:16:53 -050026GROUPADD_PARAM:${PN} = "priv-admin; priv-operator; priv-user "
27GROUPADD_PARAM:phosphor-ldap = "priv-admin; priv-operator; priv-user "
Richard Marian Thomaiyar7a8e9b22018-12-14 09:04:40 +053028
Patrick Williams12fc9392021-08-06 09:16:53 -050029DBUS_SERVICE:${PN} += "xyz.openbmc_project.User.Manager.service"
30FILES:phosphor-ldap += " \
Patrick Ventured8014ce2019-04-04 10:03:09 -070031 ${bindir}/phosphor-ldap-conf \
32 ${bindir}/phosphor-ldap-mapper \
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050033"
Anton D. Kachalov31ecbfb2021-04-21 19:23:55 +020034FILES:${PN} += " \
35 ${base_libdir}/systemd \
Andrew Geissler30cd3822021-10-15 01:41:20 +000036 ${datadir}/dbus-1 \
Anton D. Kachalov31ecbfb2021-04-21 19:23:55 +020037 ${datadir}/phosphor-certificate-manager \
38"
Patrick Williams12fc9392021-08-06 09:16:53 -050039DBUS_SERVICE:phosphor-ldap = " \
Tom Joseph42276262018-10-07 05:51:04 -050040 xyz.openbmc_project.Ldap.Config.service \
41 xyz.openbmc_project.LDAP.PrivilegeMapper.service \
42"
Patrick Williamsbb99d222022-01-24 15:55:09 -060043SRC_URI += "git://github.com/openbmc/phosphor-user-manager;branch=master;protocol=https"
Andrew Geisslerb7c21d12022-01-12 03:30:45 +000044SRCREV = "ca039ca36114aaacb059abc7545073ab735c3b25"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053045S = "${WORKDIR}/git"