blob: 662c9cc705709e362b5ccd9e6a0c3627b7b148a4 [file] [log] [blame]
Joel Stanleye8f268e2018-04-23 10:50:44 +09301HOMEPAGE = "https://github.com/jk-ozlabs/fbterm"
2LICENSE = "GPLv2+"
3
Patrick Williamsbb99d222022-01-24 15:55:09 -06004SRC_URI += "git://github.com/jk-ozlabs/fbterm.git;nobranch=1;protocol=https"
Joel Stanleye8f268e2018-04-23 10:50:44 +09305SRC_URI += "file://fb.modes"
6PR = "r1"
7
8LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=d8e20eece214df8ef953ed5857862150"
9
10DEPENDS += "freetype"
11DEPENDS += "fontconfig"
12
13inherit autotools
14inherit pkgconfig
15inherit obmc-phosphor-systemd
16
17SRCREV = "c15430560aeb82a27358cc320af4a29e1296e6c1"
18PV = "1.7+git${SRCPV}"
19
20S = "${WORKDIR}/git"
21
22do_install() {
23 oe_runmake 'DESTDIR=${D}' install-exec
24 install -d ${D}${sysconfdir}/
25 install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}/
26}
27
Patrick Williams12fc9392021-08-06 09:16:53 -050028SYSTEMD_SERVICE:${PN} += "fbterm.service"
Patrick Williamse83c2202021-09-01 16:17:33 -050029SYSTEMD_ENVIRONMENT_FILE:${PN} += "fbterm"