blob: c9e6e412be317560af58d9f74516c96cc8e53394 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001KBRANCH ?= "v4.14/standard/tiny/common-pc"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
Brad Bishopbba38f32018-08-23 16:11:46 +08007LINUX_VERSION ?= "4.14.67"
Brad Bishop316dfdd2018-06-25 12:45:53 -04008
9DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
10DEPENDS += "openssl-native util-linux-native"
11
12KMETA = "kernel-meta"
13KCONF_BSP_AUDIT_LEVEL = "2"
14
Brad Bishopbba38f32018-08-23 16:11:46 +080015SRCREV_machine ?= "74ecbeb03ebfc2b9a73a6554924b043b903295f5"
16SRCREV_meta ?= "c43c9e19a22367b48c0f62764c8555643d2a6844"
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
18PV = "${LINUX_VERSION}+git${SRCPV}"
19
20SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
21 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
22
23COMPATIBLE_MACHINE = "qemux86|qemux86-64"
24
25# Functionality flags
26KERNEL_FEATURES = ""
27
28KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"